LOGIN ID Password Auto Login Register Now! Lost Password?
Xoops Q&A

phpのバージョン変更で正しく作動しなくなりました。

  • このフォーラムに新しいトピックを立てることはできません
  • このフォーラムではゲスト投稿が禁止されています

投稿ツリー


前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2014/7/3 1:23
mini100  2nd Class   投稿数: 22
サイトで
XOOPS Cube Legacy 2.1.8を使用しておりました。
昔作ったサイトで知人が管理していたのですが
いつの間にかPHPのバージョンが5.3に上がっており
互換性が微妙になかったのか

Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacy/preload/InstallerChecker.class.php line 32
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacy/preload/ThemeSelect.class.php line 32
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacyRender/preload/Cacheclear.class.php line 26
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacyRender/preload/Cacheclear.class.php line 29
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file kernel/member.php line 79
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file kernel/member.php line 80
Unknown Condition [8192]: Assigning the return value of new by reference is deprecated in file kernel/member.php line 81

などよくわからないエラーが表示されてしまっています

PHPデバックがなぜかオンになってしまっていましたので
とりあえずエラー表示だけでも消そうと
しましたが管理画面から変更しようとしても
ERRORsitenameUnknown Condition [8192]: Assigning the return value of new by reference is deprecated in file modules/legacy/preload/InstallerChecker.class.php line 32

というエラーが出て変更できません。

debugchange.php
というもので変更できるという記事を見つけたのですが
リンク先がなくなっておりダウンロードできず
変更も出来ず困り果てております。

なんとかエラーを消す方法はないでしょうか?
PHPのバージョンは5.3以下には変更できないみたいでして
なんとか現状のままエラーだけ消せればと思っています。

焦り過ぎて意味不明な文になっているかと思いますが
よろしくお願いいたします。
投票数:0 平均点:0.00
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2014/7/3 22:23
nao-pon  Lieutenant   投稿数: 484
mini100 さん、こんにちは。

XCL 2.1.8 は、かなり前のバージョンになりますので、新しい PHP に対応できていない部分があります。また、リリース後に発見された脆弱性もそのままになっていると思われますので、最新バージョン(現状で XCL 2.2.3) へのアップグレードを強くお勧めします。

アップグレードされる場合は、ブラウザで本体や各種モジュールのアップデートやインストールが可能になる X-update モジュールがバンドルされた XOOPS X (ten) ディストリビューションをお薦めします。

次の URL よりダウンロードできます。

- https://github.com/xoopscube/legacy/archive/CorePack.zip

アップグレードについては、次の URL などを参考にしてください。

- XOOPS Cube日本サイト - doc : インストールパッケージについて [インストールガイド]
投票数:0 平均点:0.00
  条件検索へ

Back to Page Top
MainMenu
Manuals
Search
XOOPS Official & Dev.
XOOPS Communities